package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)word1[^;\n]*(?:\R[^;\n]*?){0,5}word2`)
var str = ` any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text word2
any random text any random text;
any random text word1 any random text
any random word2 text any random text word2
any random text any random text
any random text word2 any random text
any random text any random text word2 any random text;
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text
any random text any random text any random text;
any random text any random text word2
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text
any random text word2 any random text;
any random text word1 any random text;
any random word2 text any random text word2
any random text any random text
any random text word2 any random text
any random text any random text word2 any random text;
any random text word1 any random text;
any random text any random text
any random text any random text
any random text any random text
any random text word2 any random text;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}