use strict;
my $str = ' any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text word2
any random text any random text;
any random text word1 any random text
any random word2 text any random text word2
any random text any random text
any random text word2 any random text
any random text any random text word2 any random text;
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text
any random text any random text any random text;
any random text any random text word2
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text
any random text word2 any random text;
any random text word1 any random text;
any random word2 text any random text word2
any random text any random text
any random text word2 any random text
any random text any random text word2 any random text;
any random text word1 any random text;
any random text any random text
any random text any random text
any random text any random text
any random text word2 any random text;';
my $regex = qr/word1[^;\n]*(?:\R[^;\n]*?){0,5}word2/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}