// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)word1[^;\n]*(?:\R[^;\n]*?){0,5}word2").unwrap();
let string = " any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text word2
any random text any random text;
any random text word1 any random text
any random word2 text any random text word2
any random text any random text
any random text word2 any random text
any random text any random text word2 any random text;
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text
any random text any random text any random text;
any random text any random text word2
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text
any random text word2 any random text;
any random text word1 any random text;
any random word2 text any random text word2
any random text any random text
any random text word2 any random text
any random text any random text word2 any random text;
any random text word1 any random text;
any random text any random text
any random text any random text
any random text any random text
any random text word2 any random text;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}