import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "word1[^;\\n]*(?:\\R[^;\\n]*?){0,5}word2";
final String string = " any random text word1 any random text\n"
+ " any random text any random text\n"
+ " any random text any random text\n"
+ " any random text any random text word2\n"
+ " any random text any random text;\n\n"
+ " any random text word1 any random text\n"
+ " any random word2 text any random text word2\n"
+ " any random text any random text\n"
+ " any random text word2 any random text\n"
+ " any random text any random text word2 any random text;\n\n"
+ " any random text word1 any random text\n"
+ " any random text any random text\n"
+ " any random text any random text\n"
+ " any random text any random text\n"
+ " any random text any random text any random text;\n"
+ " any random text any random text word2\n\n"
+ " any random text word1 any random text\n"
+ " any random text any random text\n"
+ " any random text any random text\n"
+ " any random text any random text\n"
+ " any random text word2 any random text;\n\n"
+ " any random text word1 any random text;\n"
+ " any random word2 text any random text word2\n"
+ " any random text any random text\n"
+ " any random text word2 any random text\n"
+ " any random text any random text word2 any random text;\n\n"
+ " any random text word1 any random text;\n"
+ " any random text any random text\n"
+ " any random text any random text\n"
+ " any random text any random text\n"
+ " any random text word2 any random text;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}