re = /word1[^;\n]*(?:\R[^;\n]*?){0,5}word2/mi
str = ' any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text word2
any random text any random text;
any random text word1 any random text
any random word2 text any random text word2
any random text any random text
any random text word2 any random text
any random text any random text word2 any random text;
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text
any random text any random text any random text;
any random text any random text word2
any random text word1 any random text
any random text any random text
any random text any random text
any random text any random text
any random text word2 any random text;
any random text word1 any random text;
any random word2 text any random text word2
any random text any random text
any random text word2 any random text
any random text any random text word2 any random text;
any random text word1 any random text;
any random text any random text
any random text any random text
any random text any random text
any random text word2 any random text;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end