$re = '/^#\s(\d+)\s+-?(\d{2}):(\d{2})\.(\d{3})\s(\d+)\s(\d{2}:\d{2})$/m';
$str = 'StNr      Laptime       Lap     Tageszeit
# 665	-02:04.137	6	10:52
# 665	-01:47.625	5	10:50
# 665	-01:49.546	4	10:48
# 665	-01:57.014	3	10:47
# 665	-01:51.407	2	10:45
# 665	-00:00.000	1	10:43
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);