import re
regex = re.compile(r"^#\s(\d+)\s+-?(\d{2}):(\d{2})\.(\d{3})\s(\d+)\s(\d{2}:\d{2})$", flags=re.MULTILINE)
test_str = ("StNr Laptime Lap Tageszeit\n"
"# 665 -02:04.137 6 10:52\n"
"# 665 -01:47.625 5 10:50\n"
"# 665 -01:49.546 4 10:48\n"
"# 665 -01:57.014 3 10:47\n"
"# 665 -01:51.407 2 10:45\n"
"# 665 -00:00.000 1 10:43\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")