using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(
(\+\d-\d{3}-\d{3}-\d{4}) (?# telefone)
\s ([\w\s\.]+) \s (?# endereço)
(\<\p{Lu}\s\p{Lu}\p{Ll}+\>) (?# nome)
)
|
( (.+?) (?# parte do endereço)
((?4)) (?# reaproveita a regex do nome)
(.+?) (?# parte 2 endereço)
((?2)) (?# reaproveita a regex do telefone)
)
";
string input = @"+1-541-754-3010 156 Alphand_St. <J Steeve>
133, Green, Rd. <E Kustur> NY-56423 ;+1-541-914-3010";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}