import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( \n"
+ " (\\+\\d-\\d{3}-\\d{3}-\\d{4}) (?# telefone)\n"
+ " \\s ([\\w\\s\\.]+) \\s (?# endereço)\n"
+ " (\\<\\p{Lu}\\s\\p{Lu}\\p{Ll}+\\>) (?# nome)\n"
+ ") \n"
+ "|\n"
+ "( (.+?) (?# parte do endereço)\n"
+ " ((?4)) (?# reaproveita a regex do nome)\n"
+ " (.+?) (?# parte 2 endereço)\n"
+ " ((?2)) (?# reaproveita a regex do telefone)\n"
+ ")\n";
final String string = "+1-541-754-3010 156 Alphand_St. <J Steeve>\n"
+ "133, Green, Rd. <E Kustur> NY-56423 ;+1-541-914-3010";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}