use strict;
my $str = '+1-541-754-3010 156 Alphand_St. <J Steeve>
133, Green, Rd. <E Kustur> NY-56423 ;+1-541-914-3010';
my $regex = qr/(
(\+\d-\d{3}-\d{3}-\d{4}) (?# telefone)
\s ([\w\s\.]+) \s (?# endereço)
(\<\p{Lu}\s\p{Lu}\p{Ll}+\>) (?# nome)
)
|
( (.+?) (?# parte do endereço)
((?4)) (?# reaproveita a regex do nome)
(.+?) (?# parte 2 endereço)
((?2)) (?# reaproveita a regex do telefone)
)
/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}