const regex = /(
(\+\d-\d{3}-\d{3}-\d{4}) (?# telefone)
\s ([\w\s\.]+) \s (?# endereço)
(\<\p{Lu}\s\p{Lu}\p{Ll}+\>) (?# nome)
)
|
( (.+?) (?# parte do endereço)
((?4)) (?# reaproveita a regex do nome)
(.+?) (?# parte 2 endereço)
((?2)) (?# reaproveita a regex do telefone)
)
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(
(\\+\\d-\\d{3}-\\d{3}-\\d{4}) (?# telefone)
\\s ([\\w\\s\\.]+) \\s (?# endereço)
(\\<\\p{Lu}\\s\\p{Lu}\\p{Ll}+\\>) (?# nome)
)
|
( (.+?) (?# parte do endereço)
((?4)) (?# reaproveita a regex do nome)
(.+?) (?# parte 2 endereço)
((?2)) (?# reaproveita a regex do telefone)
)
', 'gm')
const str = `+1-541-754-3010 156 Alphand_St. <J Steeve>
133, Green, Rd. <E Kustur> NY-56423 ;+1-541-914-3010`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}