re = /(
(\+\d-\d{3}-\d{3}-\d{4}) (?# telefone)
\s ([\w\s\.]+) \s (?# endereço)
(\<\p{Lu}\s\p{Lu}\p{Ll}+\>) (?# nome)
)
|
( (.+?) (?# parte do endereço)
((?4)) (?# reaproveita a regex do nome)
(.+?) (?# parte 2 endereço)
((?2)) (?# reaproveita a regex do telefone)
)
/mx
str = '+1-541-754-3010 156 Alphand_St. <J Steeve>
133, Green, Rd. <E Kustur> NY-56423 ;+1-541-914-3010'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end