#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s?(\w+)(?=:)"
Local $sString = "Martin: Let's show Mr. Hooper our, uh, hex. Here. " +" & @CRLF & _
" "Hooper: Ah, victim identified as Christine Watkins. Female Caucasian. " +" & @CRLF & _
" "Martin: Yeah now, now here's where we have it. " +" & @CRLF & _
" "Hooper: Probable boating accident. Martin: Yeah. " +" & @CRLF & _
" "Hooper: The height and weight of the victim can only be estimated from the partial remains. The torso has been severed in mid-thorax. There are no major organs remain."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")