import re
regex = re.compile(r"\s?(\w+)(?=:)", flags=re.MULTILINE)
test_str = ("Martin: Let's show Mr. Hooper our, uh, hex. Here. \" +\n"
" \"Hooper: Ah, victim identified as Christine Watkins. Female Caucasian. \" +\n"
" \"Martin: Yeah now, now here's where we have it. \" +\n"
" \"Hooper: Probable boating accident. Martin: Yeah. \" +\n"
" \"Hooper: The height and weight of the victim can only be estimated from the partial remains. The torso has been severed in mid-thorax. There are no major organs remain.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")