import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s?(\\w+)(?=:)";
final String string = "Martin: Let's show Mr. Hooper our, uh, hex. Here. \" +\n"
+ " \"Hooper: Ah, victim identified as Christine Watkins. Female Caucasian. \" +\n"
+ " \"Martin: Yeah now, now here's where we have it. \" +\n"
+ " \"Hooper: Probable boating accident. Martin: Yeah. \" +\n"
+ " \"Hooper: The height and weight of the victim can only be estimated from the partial remains. The torso has been severed in mid-thorax. There are no major organs remain.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}