#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)d-[0-9a-fA-F]{32}"
Local $sString = "d-baeb9610e69043be9d315d7e351aaaaa" & @CRLF & _
"d-baeb9610e69043be9d315d7e351aaaaa" & @CRLF & _
"d-b776a0bdace0449c81ca4284683fffff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")