using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"d-[0-9a-fA-F]{32}";
string input = @"d-baeb9610e69043be9d315d7e351aaaaa
d-baeb9610e69043be9d315d7e351aaaaa
d-b776a0bdace0449c81ca4284683fffff";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}