const regex = new RegExp('d-[0-9a-fA-F]{32}', 'gm')
const str = `d-baeb9610e69043be9d315d7e351aaaaa
d-baeb9610e69043be9d315d7e351aaaaa
d-b776a0bdace0449c81ca4284683fffff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}