// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)d-[0-9a-fA-F]{32}").unwrap();
let string = "d-baeb9610e69043be9d315d7e351aaaaa
d-baeb9610e69043be9d315d7e351aaaaa
d-b776a0bdace0449c81ca4284683fffff";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}