package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)d-[0-9a-fA-F]{32}`)
var str = `d-baeb9610e69043be9d315d7e351aaaaa
d-baeb9610e69043be9d315d7e351aaaaa
d-b776a0bdace0449c81ca4284683fffff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}