use strict;
my $str = 'd-baeb9610e69043be9d315d7e351aaaaa
d-baeb9610e69043be9d315d7e351aaaaa
d-b776a0bdace0449c81ca4284683fffff';
my $regex = qr`d-[0-9a-fA-F]{32}`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}