#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?si)Main Idea #2\RGreat:.*?\RNot so great:\h*(.+?)(?:Main Idea|$)"
Local $sString = "Main Idea #1" & @CRLF & _
"Great: Everything (examples...)" & @CRLF & _
"Not so great: Only one thing (examples)" & @CRLF & _
"Main Idea #2" & @CRLF & _
"Great: Everything (examples...)" & @CRLF & _
"and add a second line to Great" & @CRLF & _
"Not so great: Only one thing (examples)" & @CRLF & _
"and add a second line to NSG" & @CRLF & _
"Main Idea #3" & @CRLF & _
"Great: Everything (examples...)" & @CRLF & _
"Not so great: Only one thing (examples)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"So I would need a expression that does:" & @CRLF & _
"" & @CRLF & _
"Look for "Not so great: "" & @CRLF & _
"Make sure it's the one after the text "Main Idea #2"" & @CRLF & _
"Copy everything after "Not so great: " up until the text "Main Idea #3"" & @CRLF & _
"Put it into the clipboard"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")