use strict;
my $str = 'Main Idea #1
Great: Everything (examples...)
Not so great: Only one thing (examples)
Main Idea #2
Great: Everything (examples...)
and add a second line to Great
Not so great: Only one thing (examples)
and add a second line to NSG
Main Idea #3
Great: Everything (examples...)
Not so great: Only one thing (examples)
So I would need a expression that does:
Look for "Not so great: "
Make sure it\'s the one after the text "Main Idea #2"
Copy everything after "Not so great: " up until the text "Main Idea #3"
Put it into the clipboard';
my $regex = qr/(?si)Main Idea #2\RGreat:.*?\RNot so great:\h*(.+?)(?:Main Idea|$)/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}