const regex = /(?si)Main Idea #2\RGreat:.*?\RNot so great:\h*(.+?)(?:Main Idea|$)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?si)Main Idea #2\\RGreat:.*?\\RNot so great:\\h*(.+?)(?:Main Idea|$)', 'gu')
const str = `Main Idea #1
Great: Everything (examples...)
Not so great: Only one thing (examples)
Main Idea #2
Great: Everything (examples...)
and add a second line to Great
Not so great: Only one thing (examples)
and add a second line to NSG
Main Idea #3
Great: Everything (examples...)
Not so great: Only one thing (examples)
So I would need a expression that does:
Look for "Not so great: "
Make sure it's the one after the text "Main Idea #2"
Copy everything after "Not so great: " up until the text "Main Idea #3"
Put it into the clipboard`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}