# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?si)Main Idea #2\RGreat:.*?\RNot so great:\h*(.+?)(?:Main Idea|$)"
test_str = ("Main Idea #1\n"
"Great: Everything (examples...)\n"
"Not so great: Only one thing (examples)\n"
"Main Idea #2\n"
"Great: Everything (examples...)\n"
"and add a second line to Great\n"
"Not so great: Only one thing (examples)\n"
"and add a second line to NSG\n"
"Main Idea #3\n"
"Great: Everything (examples...)\n"
"Not so great: Only one thing (examples)\n\n\n"
"So I would need a expression that does:\n\n"
"Look for \"Not so great: \"\n"
"Make sure it's the one after the text \"Main Idea #2\"\n"
"Copy everything after \"Not so great: \" up until the text \"Main Idea #3\"\n"
"Put it into the clipboard")
matches = re.finditer(regex, test_str, re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.