$re = '/(?si)Main Idea #2\RGreat:.*?\RNot so great:\h*(.+?)(?:Main Idea|$)/u';
$str = 'Main Idea #1
Great: Everything (examples...)
Not so great: Only one thing (examples)
Main Idea #2
Great: Everything (examples...)
and add a second line to Great
Not so great: Only one thing (examples)
and add a second line to NSG
Main Idea #3
Great: Everything (examples...)
Not so great: Only one thing (examples)
So I would need a expression that does:
Look for "Not so great: "
Make sure it\'s the one after the text "Main Idea #2"
Copy everything after "Not so great: " up until the text "Main Idea #3"
Put it into the clipboard';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);