import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?si)Main Idea #2\\RGreat:.*?\\RNot so great:\\h*(.+?)(?:Main Idea|$)";
final String string = "Main Idea #1\n"
+ "Great: Everything (examples...)\n"
+ "Not so great: Only one thing (examples)\n"
+ "Main Idea #2\n"
+ "Great: Everything (examples...)\n"
+ "and add a second line to Great\n"
+ "Not so great: Only one thing (examples)\n"
+ "and add a second line to NSG\n"
+ "Main Idea #3\n"
+ "Great: Everything (examples...)\n"
+ "Not so great: Only one thing (examples)\n\n\n"
+ "So I would need a expression that does:\n\n"
+ "Look for \"Not so great: \"\n"
+ "Make sure it's the one after the text \"Main Idea #2\"\n"
+ "Copy everything after \"Not so great: \" up until the text \"Main Idea #3\"\n"
+ "Put it into the clipboard";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}