#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{1,3}(,\d{3})*|\d+|\d{2}(?:,\d{2})*,\d{3})(?:\.\d+)?$"
Local $sString = "--valid--" & @CRLF & _
"1000" & @CRLF & _
"1000.12" & @CRLF & _
"1,000" & @CRLF & _
"1,000.12" & @CRLF & _
"10,000" & @CRLF & _
"10,000.12" & @CRLF & _
"10,000,000" & @CRLF & _
"10,000,000.12" & @CRLF & _
"10,00,00,000" & @CRLF & _
"10,00,00,000.12" & @CRLF & _
"" & @CRLF & _
"--invalid--" & @CRLF & _
"100," & @CRLF & _
"1000." & @CRLF & _
"1000.12," & @CRLF & _
"1000.12.34" & @CRLF & _
"1000,.12" & @CRLF & _
",1000" & @CRLF & _
",1000.12" & @CRLF & _
"1,,000" & @CRLF & _
"1,,00.12" & @CRLF & _
".12" & @CRLF & _
",,,,,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")