using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d{1,3}(,\d{3})*|\d+|\d{2}(?:,\d{2})*,\d{3})(?:\.\d+)?$";
string input = @"--valid--
1000
1000.12
1,000
1,000.12
10,000
10,000.12
10,000,000
10,000,000.12
10,00,00,000
10,00,00,000.12
--invalid--
100,
1000.
1000.12,
1000.12.34
1000,.12
,1000
,1000.12
1,,000
1,,00.12
.12
,,,,,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}