import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{1,3}(,\\d{3})*|\\d+|\\d{2}(?:,\\d{2})*,\\d{3})(?:\\.\\d+)?$";
final String string = "--valid--\n"
+ "1000\n"
+ "1000.12\n"
+ "1,000\n"
+ "1,000.12\n"
+ "10,000\n"
+ "10,000.12\n"
+ "10,000,000\n"
+ "10,000,000.12\n"
+ "10,00,00,000\n"
+ "10,00,00,000.12\n\n"
+ "--invalid--\n"
+ "100,\n"
+ "1000.\n"
+ "1000.12,\n"
+ "1000.12.34\n"
+ "1000,.12\n"
+ ",1000\n"
+ ",1000.12\n"
+ "1,,000\n"
+ "1,,00.12\n"
+ ".12\n"
+ ",,,,,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}