# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\d{1,3}(,\d{3})*|\d+|\d{2}(?:,\d{2})*,\d{3})(?:\.\d+)?$"
test_str = ("--valid--\n"
"1000\n"
"1000.12\n"
"1,000\n"
"1,000.12\n"
"10,000\n"
"10,000.12\n"
"10,000,000\n"
"10,000,000.12\n"
"10,00,00,000\n"
"10,00,00,000.12\n\n"
"--invalid--\n"
"100,\n"
"1000.\n"
"1000.12,\n"
"1000.12.34\n"
"1000,.12\n"
",1000\n"
",1000.12\n"
"1,,000\n"
"1,,00.12\n"
".12\n"
",,,,,")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.