package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{1,3}(,\d{3})*|\d+|\d{2}(?:,\d{2})*,\d{3})(?:\.\d+)?$`)
var str = `--valid--
1000
1000.12
1,000
1,000.12
10,000
10,000.12
10,000,000
10,000,000.12
10,00,00,000
10,00,00,000.12
--invalid--
100,
1000.
1000.12,
1000.12.34
1000,.12
,1000
,1000.12
1,,000
1,,00.12
.12
,,,,,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}