# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(https?:\\/\\/|(www\.)?[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}(:[0-9]{1,5})?(\\/.*)?)/[x]/gm;t' <<< "Our website is <a href=\"www.me.com\">www.me.com</a>
Our website is <a href=\"me.com\">me.com</a>
Our website is <a href=\"http://www.me.com\">http://www.me.com</a>
Our website is <a href=\"https://www.me.com\">https://www.me.com</a>"