package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/|(www\.)?[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}(:[0-9]{1,5})?(\/.*)?)`)
var str = `Our website is <a href="www.me.com">www.me.com</a>
Our website is <a href="me.com">me.com</a>
Our website is <a href="http://www.me.com">http://www.me.com</a>
Our website is <a href="https://www.me.com">https://www.me.com</a>`
var substitution = "[x]"
fmt.Println(re.ReplaceAllString(str, substitution))
}