import Foundation
let pattern = #"(https?:\/\/|(www\.)?[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}(:[0-9]{1,5})?(\/.*)?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Our website is <a href="www.me.com">www.me.com</a>
Our website is <a href="me.com">me.com</a>
Our website is <a href="http://www.me.com">http://www.me.com</a>
Our website is <a href="https://www.me.com">https://www.me.com</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[x]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)