const regex = /(https?:\/\/|(www\.)?[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}(:[0-9]{1,5})?(\/.*)?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/|(www\\.)?[a-z0-9]+([\\-\\.]{1}[a-z0-9]+)*\\.[a-z]{2,5}(:[0-9]{1,5})?(\\\/.*)?)', 'gm')
const str = `Our website is <a href="www.me.com">www.me.com</a>
Our website is <a href="me.com">me.com</a>
Our website is <a href="http://www.me.com">http://www.me.com</a>
Our website is <a href="https://www.me.com">https://www.me.com</a>`;
const subst = `[x]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);