// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https?:\/\/|(www\.)?[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}(:[0-9]{1,5})?(\/.*)?)").unwrap();
let string = "Our website is <a href=\"www.me.com\">www.me.com</a>
Our website is <a href=\"me.com\">me.com</a>
Our website is <a href=\"http://www.me.com\">http://www.me.com</a>
Our website is <a href=\"https://www.me.com\">https://www.me.com</a>";
let substitution = "[x]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}