$re = '/(https?:\/\/|(www\.)?[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}(:[0-9]{1,5})?(\/.*)?)/m';
$str = 'Our website is <a href="www.me.com">www.me.com</a>
Our website is <a href="me.com">me.com</a>
Our website is <a href="http://www.me.com">http://www.me.com</a>
Our website is <a href="https://www.me.com">https://www.me.com</a>';
$subst = "[x]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;