using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[\£\$\€]{1}[,\d]+.?\d*)";
string input = @"I bought a car $12,250,000 it was expensive
that thing was £14,500,123.125521 dollas
afsaf£120.25sfsafsa
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}