import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\£\\$\\€]{1}[,\\d]+.?\\d*)";
final String string = "I bought a car $12,250,000 it was expensive \n"
+ "that thing was £14,500,123.125521 dollas \n"
+ "afsaf£120.25sfsafsa \n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}