// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:[\£\$\€]{1}[,\d]+.?\d*)").unwrap();
let string = "I bought a car $12,250,000 it was expensive
that thing was £14,500,123.125521 dollas
afsaf£120.25sfsafsa
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}