$re = '/(?:[\£\$\€]{1}[,\d]+.?\d*)/';
$str = 'I bought a car $12,250,000 it was expensive
that thing was £14,500,123.125521 dollas
afsaf£120.25sfsafsa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);