const regex = /(?:[\£\$\€]{1}[,\d]+.?\d*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[\\£\\$\\€]{1}[,\\d]+.?\\d*)', 'g')
const str = `I bought a car \$12,250,000 it was expensive
that thing was £14,500,123.125521 dollas
afsaf£120.25sfsafsa
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}