const regex = new RegExp('^(?P<start>\\d+)[\\s\\-_]+(?:(?:\\w+[\\s\\-_]+)?(?P<end>\\d+)[\\s\\-_]+)?', 'gm')
const str = `10407_10415_10416_Autopath_DATA_SUMMARY.xlsm.From_Applicant.csv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}