$re = '/^(?P<start>\d+)[\s\-_]+(?:(?:\w+[\s\-_]+)?(?P<end>\d+)[\s\-_]+)?/m';
$str = '10407_10415_10416_Autopath_DATA_SUMMARY.xlsm.From_Applicant.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);