re = /^(?P<start>\d+)[\s\-_]+(?:(?:\w+[\s\-_]+)?(?P<end>\d+)[\s\-_]+)?/m
str = '10407_10415_10416_Autopath_DATA_SUMMARY.xlsm.From_Applicant.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end