// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<start>\d+)[\s\-_]+(?:(?:\w+[\s\-_]+)?(?P<end>\d+)[\s\-_]+)?").unwrap();
let string = "10407_10415_10416_Autopath_DATA_SUMMARY.xlsm.From_Applicant.csv";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}