using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![a-z:])name:|:name(?![a-z:])";
string input = @"name: | :name | name:`asdf`
But should not match any of these:
:name:
eman:
nnamee:
:nameasdfj";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}