import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![a-z:])name:|:name(?![a-z:])";
final String string = "name: | :name | name:`asdf`\n\n"
+ "But should not match any of these:\n\n"
+ ":name: \n"
+ "eman: \n"
+ "nnamee: \n"
+ ":nameasdfj";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}