import re
regex = re.compile(r"(?<![a-z:])name:|:name(?![a-z:])", flags=re.MULTILINE)
test_str = ("name: | :name | name:`asdf`\n\n"
"But should not match any of these:\n\n"
":name: \n"
"eman: \n"
"nnamee: \n"
":nameasdfj")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")